Debians sikkerhedsbulletin

DSA-4659-1 git -- sikkerhedsopdatering

Rapporteret den:
20. apr 2020
Berørte pakker:
git
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2020-11008.
Yderligere oplysninger:

Carlo Arenas fra Google Project Zero opdagede en fejl i git, et hurtigt, skalerbart og distributeret versionsstyringssystem. Med en fabrikeret URL, som indeholder et linjeskift, kunne credential-helper-maskineriet blive narret til at levere brugeroplysninger, som ikke er passende i den anvendte protokol og den vært der blev kontaktet.

I den gamle stabile distribution (stretch), er dette problem rettet i version 1:2.11.0-3+deb9u7.

I den stabile distribution (buster), er dette problem rettet i version 1:2.20.1-2+deb10u3.

Vi anbefaler at du opgraderer dine git-pakker.

For detaljeret sikkerhedsstatus vedrørende git, se dens sikkerhedssporingssidede på: https://security-tracker.debian.org/tracker/git