Debians sikkerhedsbulletin

DSA-4663-1 python-reportlab -- sikkerhedsopdatering

Rapporteret den:
25. apr 2020
Berørte pakker:
python-reportlab
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 942763.
I Mitres CVE-ordbog: CVE-2019-17626.
Yderligere oplysninger:

Man opdagede at python-reportlab, et Python-bibliotek til fremstilling af PDF-dokumenter, var sårbar overfor en kodeinsprøjtningssårbarhed ved fortolkning af en farveattribut. En angriber kunne drage nytte af fejlen til at udføre vilkårlig kode, hvis et særligt fremstillet dokument blev behandlet.

I den gamle stabile distribution (stretch), er dette problem rettet i version 3.3.0-2+deb9u1.

I den stabile distribution (buster), er dette problem rettet i version 3.5.13-1+deb10u1.

Vi anbefaler at du opgraderer dine python-reportlab-pakker.

For detaljeret sikkerhedsstatus vedrørende python-reportlab, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/python-reportlab