Debians sikkerhedsbulletin

DSA-4682-1 squid -- sikkerhedsopdatering

Rapporteret den:
8. maj 2020
Berørte pakker:
squid
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2019-12519, CVE-2019-12520, CVE-2019-12521, CVE-2019-12523, CVE-2019-12524, CVE-2019-12526, CVE-2019-12528, CVE-2019-18676, CVE-2019-18677, CVE-2019-18678, CVE-2019-18679, CVE-2020-8449, CVE-2020-8450, CVE-2020-11945.
Yderligere oplysninger:

Adskillige sikkerhedsproblemer blev opdaget i proxycachingserveren Squid, hvilke kunne medføre omgåelse af sikkerhedsfiltre, informationsafsløring, udførelse af vilkårlig kode eller lammelsesangreb.

I den stabile distribution (buster), er disse problemer rettet i version 4.6-1+deb10u2.

Vi anbefaler at du opgraderer dine squid-pakker.

For detaljeret sikkerhedsstatus vedrørende squid, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/squid