Рекомендация Debian по безопасности

DSA-4689-1 bind9 -- обновление безопасности

Дата сообщения:
19.05.2020
Затронутые пакеты:
bind9
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 945171.
В каталоге Mitre CVE: CVE-2019-6477, CVE-2020-8616, CVE-2020-8617.
Более подробная информация:

В BIND, реализации DNS-сервера, было обнаружено несколько уязвимостей.

  • CVE-2019-6477

    Было обнаружено, что TCP-конвейеризированные запросы могут обходить ограничения для tcp-клиентов, что приводит к отказу в обслуживании.

  • CVE-2020-8616

    Было обнаружено, что BIND недостаточно ограничивает число вызовов, выполняемы при обработке рефералов. Злоумышленник может использовать эту уязвимость для вызова отказа в обслуживании (ухудшение производительности) или использовать обратный сервер в атаке отражением с высоким коэффициентом усиления.

  • CVE-2020-8617

    Было обнаружено, что логическая ошибка в коде, проверяющем правильность TSIG, может использоваться для вызова ошибки утверждения, что приводит к отказу в обслуживании.

В предыдущем стабильном выпуске (stretch) эти проблемы были исправлены в версии 1:9.10.3.dfsg.P4-12.3+deb9u6.

В стабильном выпуске (buster) эти проблемы были исправлены в версии 1:9.11.5.P4+dfsg-5.1+deb10u1.

Рекомендуется обновить пакеты bind9.

С подробным статусом поддержки безопасности bind9 можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/bind9