Рекомендация Debian по безопасности

DSA-4721-1 ruby2.5 -- обновление безопасности

Дата сообщения:
08.07.2020
Затронутые пакеты:
ruby2.5
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2020-10663, CVE-2020-10933.
Более подробная информация:

В интерпретаторе языка Ruby было обнаружено несколько уязвимостей.

  • CVE-2020-10663

    Джереми Эванс сообщил о небезопасном создании объекта в gem-пакете json, поставляемом в составе Ruby. При выполнении грамматического разбора определённых JSON-документов gem-пакет json может создавать произвольные объекты на целевой системе.

  • CVE-2020-10933

    Сэмуэл Уильямс сообщил об уязвимости в библиотеке socket, которая может приводить к раскрытию потенциально чувствительных данных интепретатора.

В стабильном выпуске (buster) эти проблемы были исправлены в версии 2.5.5-3+deb10u2.

Рекомендуется обновить пакеты ruby2.5.

С подробным статусом поддержки безопасности ruby2.5 можно ознакомиться на its security tracker page at: https://security-tracker.debian.org/tracker/ruby2.5