Debians sikkerhedsbulletin

DSA-4724-1 webkit2gtk -- sikkerhedsopdatering

Rapporteret den:
15. jul 2020
Berørte pakker:
webkit2gtk
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2020-9802, CVE-2020-9803, CVE-2020-9805, CVE-2020-9806, CVE-2020-9807, CVE-2020-9843, CVE-2020-9850, CVE-2020-13753.
Yderligere oplysninger:

Følgende sårbarheder er opdaget i webmotoren webkit2gtk:

  • CVE-2020-9802

    Samuel Gross opdagede at behandling af ondsindet fremstillet webindhold kunne føre til udførelse af vilkårlig kode.

  • CVE-2020-9803

    Wen Xu opdagede at behandling af ondsindet fremstillet webindhold kunne føre til udførelse af vilkårlig kode.

  • CVE-2020-9805

    En anonym efterforsker opdagede at behandling af ondsindet fremstillet webindhold kunne føre til univerel udførelse af skripter på tværs af servere.

  • CVE-2020-9806

    Wen Xu opdagede at behandling af ondsindet fremstillet webindhold kunne føre til udførelse af vilkårlig kode.

  • CVE-2020-9807

    Wen Xu opdagede at behandling af ondsindet fremstillet webindhold kunne føre til udførelse af vilkårlig kode.

  • CVE-2020-9843

    Ryan Pickren opdagede at behandling af ondsindet fremstillet webindhold kunne føre til et angreb med udførelse af skripter på tværs af servere.

  • CVE-2020-9850

    @jinmo123, @setuid0x0_ og @insu_yun_en opdagede at en fjernangriber kunne være i stand til at udføre vilkårlig kode.

  • CVE-2020-13753

    Milan Crha opdagede at en angriber kunne være i stand til at udføre kommandoer udenfor bubblewrap-sandkassen.

I den stabile distribution (buster), er disse problemer rettet i version 2.28.3-2~deb10u1.

Vi anbefaler at du opgraderer dine webkit2gtk-pakker.

For detaljeret sikkerhedsstatus vedrørende webkit2gtk, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/webkit2gtk