Debians sikkerhedsbulletin

DSA-4739-1 webkit2gtk -- sikkerhedsopdatering

Rapporteret den:
3. aug 2020
Berørte pakker:
webkit2gtk
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2020-9862, CVE-2020-9893, CVE-2020-9894, CVE-2020-9895, CVE-2020-9915, CVE-2020-9925.
Yderligere oplysninger:

Følgende sårbarheder er opdaget i webmotoren webkit2gtk:

  • CVE-2020-9862

    Ophir Lojkine opdagede at kopiering af en URL fra Web Inspector, kunne føre til kommandoindsprøjtning.

  • CVE-2020-9893

    0011 opdagede at en fjernangriber kunne være i stand til at forårsage en uventet programafslutning eller udførelse af vilkårlig kode.

  • CVE-2020-9894

    0011 opdagede at en fjernangriber kunne være i stand til at forårsage en uventet programafslutning eller udførelse af vilkårlig kode.

  • CVE-2020-9895

    Wen Xu opdagede at en fjernangriber kunne være i stand til at forårsage en uventet programafslutning eller udførelse af vilkårlig kode.

  • CVE-2020-9915

    Ayoub Ait Elmokhtar opdagede at behandling af ondsindet fremstillet webindhold kunne forhindre Content Security Policy i at blive håndhævet.

  • CVE-2020-9925

    En anonym efterforsker opdagede at behandling af ondsindet fremstillet webindhold kunne føre til universel udførelse af skripter på tværs af servere.

I den stabile distribution (buster), er disse problemer rettet i version 2.28.4-1~deb10u1.

Vi anbefaler at du opgraderer dine webkit2gtk-pakker.

For detaljeret sikkerhedsstatus vedrørende webkit2gtk, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/webkit2gtk