Debians sikkerhedsbulletin

DSA-4751-1 squid -- sikkerhedsopdatering

Rapporteret den:
27. aug 2020
Berørte pakker:
squid
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 968932, Fejl 968933, Fejl 968934.
I Mitres CVE-ordbog: CVE-2020-15810, CVE-2020-15811, CVE-2020-24606.
Yderligere oplysninger:

Flere sårbarheder blev opdaget i Squid, en komplet webproxycache, hvilke kunne medføre forespørgselsopsplitning, forespørgselssmugling (førende til cacheforgiftning) og lammelsesangreb, når der blev behandlet fabrikerede cachedigest-svarmeddelelser.

I den stabile distribution (buster), er disse problemer rettet i version 4.6-1+deb10u4.

Vi anbefaler at du opgraderer dine squid-pakker.

For detaljeret sikkerhedsstatus vedrørende squid, se dens sikkerhedssporingssidede på: https://security-tracker.debian.org/tracker/squid