Рекомендация Debian по безопасности

DSA-4761-1 zeromq3 -- обновление безопасности

Дата сообщения:
07.09.2020
Затронутые пакеты:
zeromq3
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2020-15166.
Более подробная информация:

Было обнаружено, что ZeroMQ, упрощённая библиотека сообщений ядра, неправильно выполняет подключение одноранговых участников до завершения рукопожатия. Удалённый неаутентифицированный клиент, подключающийся к приложению, использующему библиотеку libzmq с ожидающим соединение сокетом, на котором включено шифрование/аутентификация с помощью CURVE, может использовать эту уязвимость для вызова отказа в обслуживании, влияющего на аутентифицированных клиентов, использующих шифрование.

В стабильном выпуске (buster) эта проблема была исправлена в версии 4.3.1-4+deb10u2.

Рекомендуется обновить пакеты zeromq3.

С подробным статусом поддержки безопасности zeromq3 можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/zeromq3