Debians sikkerhedsbulletin

DSA-4785-1 raptor2 -- sikkerhedsopdatering

Rapporteret den:
7. nov 2020
Berørte pakker:
raptor2
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 973889.
I Mitres CVE-ordbog: CVE-2017-18926.
Yderligere oplysninger:

Man opdagede at raptor2, et RDF-fortolkningsbibliotek, var ramt af heapbaserede bufferoverløbsfejl, hvilke kunne medføre lammelsesangreb eller potentielt udførelse af vilkårlig kode, hvis en særligt fremstillet fil blev behandlet.

I den stabile distribution (buster), er dette problem rettet i version 2.0.14-1.1~deb10u1.

Vi anbefaler at du opgraderer dine raptor2-pakker.

For detaljeret sikkerhedsstatus vedrørende raptor2, se dens sikkerhedssporingssidede på: https://security-tracker.debian.org/tracker/raptor2