Aviso de seguridad de Debian

DSA-4785-1 raptor2 -- actualización de seguridad

Fecha del informe:
7 de nov de 2020
Paquetes afectados:
raptor2
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 973889.
En el diccionario CVE de Mitre: CVE-2017-18926.
Información adicional:

Se descubrió que raptor2, una biblioteca para análisis sintáctico de RDF, tiene propensión a defectos de desbordamiento de memoria dinámica («heap»), lo que podría dar lugar a denegación de servicio o, potencialmente, a ejecución de código arbitrario si se procesa un fichero preparado de una manera determinada.

Para la distribución «estable» (buster), este problema se ha corregido en la versión 2.0.14-1.1~deb10u1.

Le recomendamos que actualice los paquetes de raptor2.

Para información detallada sobre el estado de seguridad de raptor2, consulte su página en el sistema de seguimiento de problemas de seguridad: https://security-tracker.debian.org/tracker/raptor2