Bulletin d'alerte Debian

DSA-4791-1 pacemaker -- Mise à jour de sécurité

Date du rapport :
13 novembre 2020
Paquets concernés :
pacemaker
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 973254.
Dans le dictionnaire CVE du Mitre : CVE-2020-25654.
Plus de précisions :

Ken Gaillot a découvert une vulnérabilité dans le gestionnaire de ressources de grappe Pacemaker : si les ACL ont été configurées pour des utilisateurs dans le groupe haclient, les restrictions d'ACL pourraient être contournées au moyen d'une communication inter-processus non restreinte, avec pour conséquence l'exécution de code arbitraire dans toute la grappe avec les privilèges du superutilisateur.

Si l'option de grappe >enable-acl n'est pas activée, les membres du groupe haclient peuvent modifier sans restriction la base d'informations de grappe de Pacemaker, qui leur donne déjà ces capacités, aussi, il n'y a pas d'exposition supplémentaire avec une telle configuration.

Pour la distribution stable (Buster), ce problème a été corrigé dans la version 2.0.1-5+deb10u1.

Nous vous recommandons de mettre à jour vos paquets pacemaker.

Pour disposer d'un état détaillé sur la sécurité de pacemaker, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/pacemaker.