Aviso de seguridad de Debian

DSA-4814-1 xerces-c -- actualización de seguridad

Fecha del informe:
17 de dic de 2020
Paquetes afectados:
xerces-c
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 947431.
En el diccionario CVE de Mitre: CVE-2018-1311.
Información adicional:

Se descubrió que xerces-c, una biblioteca de análisis sintáctico y validación de XML para C++, no analizaba correctamente las DTD. La vulnerabilidad de «uso tras liberar» resultante de este problema permitiría que un atacante remoto se valiera de un fichero XML preparado de una manera determinada para provocar la caída de la aplicación o, potencialmente, para ejecutar código arbitrario. Tenga en cuenta que el parche que corrige este problema lo hace a costa de introducir una fuga de contenido de la memoria.

Para la distribución «estable» (buster), este problema se ha corregido en la versión 3.2.2+debian-1+deb10u1.

Le recomendamos que actualice los paquetes de xerces-c.

Para información detallada sobre el estado de seguridad de xerces-c, consulte su página en el sistema de seguimiento de problemas de seguridad: https://security-tracker.debian.org/tracker/xerces-c