Bulletin d'alerte Debian

DSA-4814-1 xerces-c -- Mise à jour de sécurité

Date du rapport :
17 décembre 2020
Paquets concernés :
xerces-c
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 947431.
Dans le dictionnaire CVE du Mitre : CVE-2018-1311.
Plus de précisions :

xerces-c, une bibliothèque d'analyse et de validation de XML pour C++, ne parcourait pas correctement les DTD. La vulnérabilité d'utilisation de mémoire après libération résultant de ce problème pourrait permettre à un attaquant distant d'exploiter un fichier XML contrefait pour l'occasion pour faire planter l'application ou éventuellement exécuter du code arbitraire. Veuillez noter que le correctif de ces problèmes est produit au prix d'une fuite de mémoire nouvellement introduite.

Pour la distribution stable (Buster), ce problème a été corrigé dans la version 3.2.2+debian-1+deb10u1.

Nous vous recommandons de mettre à jour vos paquets xerces-c.

Pour disposer d'un état détaillé sur la sécurité de xerces-c, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/xerces-c.