Debians sikkerhedsbulletin

DSA-4880-1 lxml -- sikkerhedsopdatering

Rapporteret den:
29. mar 2021
Berørte pakker:
lxml
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 985643.
I Mitres CVE-ordbog: CVE-2021-28957.
Yderligere oplysninger:

Kevin Chung opdagede at lxml, en Python-binding bibliotekerne til libxml2 og libxslt, ikke på korrekt vis rensede sine inddata. Dermed kunne en ondsindet brugere iværksætte et angreb i forbindelse med udførelse af skripter på tværs af websteder.

I den stabile distribution (buster), er dette problem rettet i version 4.3.2-1+deb10u3.

Vi anbefaler at du opgraderer dine lxml-pakker.

For detaljeret sikkerhedsstatus vedrørende lxml, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/lxml