Aviso de seguridad de Debian

DSA-4918-1 ruby-rack-cors -- actualización de seguridad

Fecha del informe:
18 de may de 2021
Paquetes afectados:
ruby-rack-cors
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 944849.
En el diccionario CVE de Mitre: CVE-2019-18978.
Información adicional:

El tratamiento incorrecto de nombres de ruta en ruby-rack-cors, un middleware que hace compatibles con CORS las aplicaciones basadas en Rack, puede permitir el acceso a recursos privados.

Para la distribución «estable» (buster), este problema se ha corregido en la versión 1.0.2-1+deb10u1.

Le recomendamos que actualice los paquetes de ruby-rack-cors.

Para información detallada sobre el estado de seguridad de ruby-rack-cors, consulte su página en el sistema de seguimiento de problemas de seguridad: https://security-tracker.debian.org/tracker/ruby-rack-cors