Aviso de seguridad de Debian

DSA-4920-1 libx11 -- actualización de seguridad

Fecha del informe:
24 de may de 2021
Paquetes afectados:
libx11
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 988737.
En el diccionario CVE de Mitre: CVE-2021-31535.
Información adicional:

Roman Fiedler informó de que la falta de validación de longitudes en varias funciones proporcionadas por libx11, la biblioteca del lado cliente de X11, permite inyectar órdenes del protocolo X11 en clientes X, dando lugar a elusión de autenticación, a denegación de servicio o, potencialmente, a ejecución de código arbitrario.

Para la distribución «estable» (buster), este problema se ha corregido en la versión 2:1.6.7-1+deb10u2.

Le recomendamos que actualice los paquetes de libx11.

Para información detallada sobre el estado de seguridad de libx11, consulte su página en el sistema de seguimiento de problemas de seguridad: https://security-tracker.debian.org/tracker/libx11