Bulletin d'alerte Debian

DSA-4935-1 php7.3 -- Mise à jour de sécurité

Date du rapport :
5 juillet 2021
Paquets concernés :
php7.3
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2021-21704, CVE-2021-21705.
Plus de précisions :

Plusieurs problèmes de sécurité ont été découverts dans PHP, un langage de script généraliste à source libre couramment utilisé, qui pourraient avoir pour conséquences un contournement par contrefaçon de requête côté serveur (SSRF) de la vérification de FILTER_VALIDATE_URL et un déni de service ou éventuellement l'exécution de code arbitraire dans PDO de Firebird.

Pour la distribution stable (Buster), ces problèmes ont été corrigés dans la version 7.3.29-1~deb10u1.

Nous vous recommandons de mettre à jour vos paquets php7.3.

Pour disposer d'un état détaillé sur la sécurité de php7.3, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/php7.3.