Debians sikkerhedsbulletin

DSA-4936-1 libuv1 -- sikkerhedsopdatering

Rapporteret den:
5. jul 2021
Berørte pakker:
libuv1
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 990561.
I Mitres CVE-ordbog: CVE-2021-22918.
Yderligere oplysninger:

En læsning udenfor grænserne blev opdaget i funktionen uv__idna_to_ascii() i Libuv, et bibliotek til asynkron notifikation om events, hvilken kunne medføre lammelsesangreb eller informationsafsløring.

I den stabile distribution (buster), er dette problem rettet i version 1.24.1-1+deb10u1.

Vi anbefaler at du opgraderer dine libuv1-pakker.

For detaljeret sikkerhedsstatus vedrørende libuv1, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/libuv1