Debians sikkerhedsbulletin

DSA-5009-1 tomcat9 -- sikkerhedsopdatering

Rapporteret den:
12. nov 2021
Berørte pakker:
tomcat9
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2021-42340.
Yderligere oplysninger:

Apache Tomcat, servlet- og JSP-motoren, frigav ikke på korrekt vis en HTTP-opgraderingsforbindelse til WebSocket-forbindelse, når WebSocket-forbindelse blev lukket. Det medførte en hukommelseslækage som over tid kunne føre til lammelsesangreb gennem en OutOfMemoryError.

I den stabile distribution (bullseye), er dette problem rettet i version 9.0.43-2~deb11u3.

Vi anbefaler at du opgraderer dine tomcat9-pakker.

For detaljeret sikkerhedsstatus vedrørende tomcat9, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/tomcat9