Bulletin d'alerte Debian

DSA-5009-1 tomcat9 -- Mise à jour de sécurité

Date du rapport :
12 novembre 2021
Paquets concernés :
tomcat9
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2021-42340.
Plus de précisions :

Apache Tomcat, la servlet Tomcat et le moteur JSP, ne libérait pas correctement une connexion Upgrade d'HTTP pour des connexions WebSocket une fois que la connexion WebSocket a été fermée. Cela créait une fuite de mémoire qui, avec le temps, pourrait conduire à un déni de service à l'aide d'une erreur « OutOfMemoryError ».

Pour la distribution stable (Bullseye), ce problème a été corrigé dans la version 9.0.43-2~deb11u3.

Nous vous recommandons de mettre à jour vos paquets tomcat9.

Pour disposer d'un état détaillé sur la sécurité de tomcat9, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/tomcat9.