Рекомендация Debian по безопасности

DSA-5010-1 libxml-security-java -- обновление безопасности

Дата сообщения:
15.11.2021
Затронутые пакеты:
libxml-security-java
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 994569.
В каталоге Mitre CVE: CVE-2021-40690.
Более подробная информация:

Apache Santuario, модуль безопасности XML для Java, уязвим к проблеме, при которой неправильно передаётся свойство secureValidation при создании KeyInfo из элемента KeyInfoReference. Это позволяет злоумышленнику некорректно использовать XPath Transform для распаковки любых локальных файлов .xml в элемент RetrievalMethod.

В предыдущем стабильном выпуске (buster) эта проблема была исправлена в версии 2.0.10-2+deb10u1.

В стабильном выпуске (bullseye) эта проблема была исправлена в версии 2.0.10-2+deb11u1.

Рекомендуется обновить пакеты libxml-security-java.

С подробным статусом поддержки безопасности libxml-security-java можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/libxml-security-java