Debians sikkerhedsbulletin

DSA-5020-1 apache-log4j2 -- sikkerhedsopdatering

Rapporteret den:
11. dec 2021
Berørte pakker:
apache-log4j2
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 959450, Fejl 1001478.
I Mitres CVE-ordbog: CVE-2021-44228, CVE-2020-9488.
Yderligere oplysninger:

Chen Zhaojun fra Alibaba Cloud Security Team opdagede en kritisk sikkerhedssårbarhed i Apache Log4j, et populært logningsframework til Java. JNDI-funktioner anvendt i opsætningen, logmeddelelser og parametre beskytter ikke mod angriberkontrolleret LDAP og andre JNDI-relaterede endpoints. En angriber, der kan kontrollere logmeddelelser eller logmeddelelsesparametre, kunne udføre vilkårlig kode indlæst fra LDAP-serverne, når erstatning af meddelelsesopslag er aktiveret. Fra version 2.15.0 er denne virkemåde som standard deaktiveret.

Denne opdatering retter også CVE-2020-9488 i den gamle stabile distribution (buster). Ukorrekt validering af certifikater med ikke overensstemmende vært i Apache Log4j SMTP-appenderen. Det kunne være muligt at opsnappe en SMTPS-forbindelse af et manden i midten-angreb, hvilket kunne lække enhver logmeddelelse, der er sendt gennem denne appender.

I den gamle stabile distribution (buster), er dette problem rettet i version 2.15.0-1~deb10u1.

I den stabile distribution (bullseye), er dette problem rettet i version 2.15.0-1~deb11u1.

Vi anbefaler at du opgraderer dine apache-log4j2-pakker.

For detaljeret sikkerhedsstatus vedrørende apache-log4j2, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/apache-log4j2