Debians sikkerhedsbulletin

DSA-5030-1 webkit2gtk -- sikkerhedsopdatering

Rapporteret den:
23. dec 2021
Berørte pakker:
webkit2gtk
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2021-30887, CVE-2021-30890.
Yderligere oplysninger:

Følgende sårbarheder er opdaget i webmotoren webkit2gtk:

  • CVE-2021-30887

    Narendra Bhati opdagede at behandling af ondsindet fremstillet webindhold, kunne føre til uventet manglende håndhævelse af Content Security Policy.

  • CVE-2021-30890

    En anonym efterforsker opdagede at behandling af ondsindet fremstillet webindhold, kunne føre til universel udførelse af skripter på tværs af servere.

I den gamle stabile distribution (buster), er disse problemer rettet i version 2.34.3-1~deb10u1.

I den stabile distribution (bullseye), er disse problemer rettet i version 2.34.3-1~deb11u1.

Vi anbefaler at du opgraderer dine webkit2gtk-pakker.

For detaljeret sikkerhedsstatus vedrørende webkit2gtk, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/webkit2gtk