Рекомендация Debian по безопасности

DSA-5030-1 webkit2gtk -- обновление безопасности

Дата сообщения:
23.12.2021
Затронутые пакеты:
webkit2gtk
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2021-30887, CVE-2021-30890.
Более подробная информация:

В веб-движке webkit2gtk были обнаружены следующие уязвимости:

  • CVE-2021-30887

    Нарендра Бхати обнаружил, что обработка специально сформированного веб-содержимого может приводить к тому, что правила безопасности содержимого не применяется.

  • CVE-2021-30890

    Анонимный исследователь обнаружил, что обработка специально сформированного веб-содержимого может приводить к межсайтовому скриптингу.

В предыдущем стабильном выпуске (buster) эти проблемы были исправлены в версии 2.34.3-1~deb10u1.

В стабильном выпуске (bullseye) эти проблемы были исправлены в версии 2.34.3-1~deb11u1.

Рекомендуется обновить пакеты webkit2gtk.

С подробным статусом поддержки безопасности webkit2gtk можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/webkit2gtk