Debians sikkerhedsbulletin

DSA-5051-1 aide -- sikkerhedsopdatering

Rapporteret den:
20. jan 2022
Berørte pakker:
aide
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2021-45417.
Yderligere oplysninger:

David Bouman opdagede en heapbaseret bufferoverløbssårbarhed i base64-funktionerne i aide, et avanceret system til opdagelse af indtrænging, hvilken kunne udløses gennem store udvidede filattributter eller ACL'er. Det kunne medføre lammelsesangreb eller rettighedsforøgelse.

I den gamle stabile distribution (buster), er dette problem rettet i version 0.16.1-1+deb10u1.

I den stabile distribution (bullseye), er dette problem rettet i version 0.17.3-4+deb11u1.

Vi anbefaler at du opgraderer dine aide-pakker.

For detaljeret sikkerhedsstatus vedrørende aide, se dens sikkerhedssporingssidede på: https://security-tracker.debian.org/tracker/aide