Bulletin d'alerte Debian

DSA-5102-1 haproxy -- Mise à jour de sécurité

Date du rapport :
13 mars 2022
Paquets concernés :
haproxy
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2022-0711.
Plus de précisions :

Un défaut a été découvert dans la manière dont HAProxy, un serveur mandataire inverse de répartition de charge rapide et fiable, traite les réponses HTTP contenant l'en-tête « Set-Cookie2 ». Cela peut avoir pour conséquence une boucle illimitée, provoquant un déni de service.

Pour la distribution stable (Bullseye), ce problème a été corrigé dans la version 2.2.9-2+deb11u3.

Nous vous recommandons de mettre à jour vos paquets haproxy.

Pour disposer d'un état détaillé sur la sécurité de haproxy, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/haproxy.