Bulletin d'alerte Debian

DSA-5122-1 gzip -- Mise à jour de sécurité

Date du rapport :
18 avril 2022
Paquets concernés :
gzip
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 1009168.
Dans le dictionnaire CVE du Mitre : CVE-2022-1271.
Plus de précisions :

cleemy desu wayo a signalé qu'un traitement incorrect de noms de fichier par zgrep dans gzip, les utilitaires de compression GNU, peut avoir pour conséquences l'écrasement de fichiers arbitraires ou l'exécution de code arbitraire lors du traitement d'un fichier dont le nom a été contrefait pour l'occasion.

Pour la distribution oldstable (Buster), ce problème a été corrigé dans la version 1.9-3+deb10u1.

Pour la distribution stable (Bullseye), ce problème a été corrigé dans la version 1.10-4+deb11u1.

Nous vous recommandons de mettre à jour vos paquets gzip.

Pour disposer d'un état détaillé sur la sécurité de gzip, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/gzip.