Bulletin d'alerte Debian

DSA-5155-1 wpewebkit -- Mise à jour de sécurité

Date du rapport :
1er juin 2022
Paquets concernés :
wpewebkit
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2022-26700, CVE-2022-26709, CVE-2022-26716, CVE-2022-26717, CVE-2022-26719, CVE-2022-30293.
Plus de précisions :

Les vulnérabilités suivantes ont été découvertes dans le moteur web WPE WebKit :

  • CVE-2022-26700

    ryuzaki a découvert que le traitement d'un contenu web contrefait pouvait conduire à l'exécution de code.

  • CVE-2022-26709

    Chijin Zhou a découvert que le traitement d'un contenu web contrefait pouvait conduire à l'exécution de code arbitraire.

  • CVE-2022-26716

    SorryMybad a découvert que le traitement d'un contenu web contrefait pouvait conduire à l'exécution de code arbitraire.

  • CVE-2022-26717

    Jeonghoon Shin a découvert que le traitement d'un contenu web contrefait pouvait conduire à l'exécution de code arbitraire.

  • CVE-2022-26719

    Dongzhuo Zhao a découvert que le traitement d'un contenu web contrefait pouvait conduire à l'exécution de code arbitraire.

  • CVE-2022-30293

    Chijin Zhou a découvert que le traitement d'un contenu web contrefait pouvait conduire à l'exécution de code arbitraire ou à un déni de service (plantage d'application).

Pour la distribution stable (Bullseye), ces problèmes ont été corrigés dans la version 2.36.3-1~deb11u1.

Nous vous recommandons de mettre à jour vos paquets wpewebkit.

Pour disposer d'un état détaillé sur la sécurité de wpewebkit, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/wpewebkit.