Bulletin d'alerte Debian

DSA-5170-1 nodejs -- Mise à jour de sécurité

Date du rapport :
27 juin 2022
Paquets concernés :
nodejs
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2021-22959, CVE-2021-22960, CVE-2021-44532, CVE-2021-44533, CVE-2022-21824, CVE-2021-44531.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans Node.js qui pouvaient avoir pour conséquences une dissimulation de requête HTTP, un contournement de vérification de certificats ou une pollution de prototype.

Pour la distribution stable (Bullseye), ces problèmes ont été corrigés dans la version 12.22.12~dfsg-1~deb11u1.

Nous vous recommandons de mettre à jour vos paquets nodejs.

Pour disposer d'un état détaillé sur la sécurité de nodejs, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/nodejs.