Bulletin d'alerte Debian

DSA-5171-1 squid -- Mise à jour de sécurité

Date du rapport :
27 juin 2022
Paquets concernés :
squid
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2021-28116, CVE-2021-46784.
Plus de précisions :

Plusieurs problèmes de sécurité ont été découverts dans le serveur mandataire et de cache Squid :

  • CVE-2021-28116

    Amos Jeffries a découvert une fuite d'informations si WCCPv2 est activé.

  • CVE-2021-46784

    Joshua Rogers a découvert qu'une erreur dans l'analyse de réponses d'un serveur Gopher peut avoir pour conséquence un déni de service.

Pour la distribution oldstable (Buster), ces problèmes ont été corrigés dans la version 4.6-1+deb10u7.

Pour la distribution stable (Bullseye), ces problèmes ont été corrigés dans la version 4.13-10+deb11u1.

Nous vous recommandons de mettre à jour vos paquets squid.

Pour disposer d'un état détaillé sur la sécurité de squid, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/squid.