Bulletin d'alerte Debian

DSA-5316-1 netty -- Mise à jour de sécurité

Date du rapport :
11 janvier 2023
Paquets concernés :
netty
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 1027180, Bogue 1014769, Bogue 1001437.
Dans le dictionnaire CVE du Mitre : CVE-2021-37136, CVE-2021-37137, CVE-2021-43797, CVE-2022-41881, CVE-2022-41915.
Plus de précisions :

Plusieurs vulnérabilités d'épuisement de mémoire, de dépassement de pile ou de dissimulation de requête HTTP ont été découvertes dans Netty, un environnement de développement de sockets client/serveur NIO en Java, qui peuvent permettre à des attaquants de provoquer un déni de service ou de contourner des restrictions lors de son utilisation comme mandataire.

Pour la distribution stable (Bullseye), ces problèmes ont été corrigés dans la version 1:4.1.48-4+deb11u1.

Nous vous recommandons de mettre à jour vos paquets netty.

Pour disposer d'un état détaillé sur la sécurité de netty, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/netty.