Debian Security Advisory

DSA-5544-1 zookeeper -- security update

Date Reported:
31 Oct 2023
Affected Packages:
zookeeper
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2023-44981.
More information:

Damien Diederen discovered that SASL quorum peer authentication within Zookeeper, a service for maintaining configuration information, was insufficiently enforced in some configurations.

For the oldstable distribution (bullseye), this problem has been fixed in version 3.4.13-6+deb11u1.

For the stable distribution (bookworm), this problem has been fixed in version 3.8.0-11+deb12u1.

We recommend that you upgrade your zookeeper packages.

For the detailed security status of zookeeper please refer to its security tracker page at: https://security-tracker.debian.org/tracker/zookeeper