[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#339829: potential patch improvements



I would ask for a small cosmetic change in the given patch.

Presently it has:

  For example:
    This: http://...
    Not This: http://...

But I think it would be more readable as:
  Not this:
    http://..
  But this:
    http://...

Also the following seems to be longer and more complicated than
necessarily and useful.

+                       if( $last_line =~ m/-[0-9][.0-9]*/ ){

could be written more simply as

+                       if( $last_line =~ m/-[0-9]/ ){

Also I don't know if I agree with the requirement that the second to
last line be m/^\.$/.  I would rather see my original, more aggressive
check:

  $description=~m/homepage/is && $description!~/^  Homepage: [^ ]*$/

Packages for which this is a false-positive (such as slash, gnudip,
and bake) will be orders of magnitudes more rare than packages which
are missed by the existing patch which are not missed by check above
(such as liblingoteach4, qgo, tcsh, maxdb-sqlcli, tik, mozart,
tagcoll, sleuthkit, tdl, xlogmaster, libsqlod75, wmpuzzle,
python2.3-dictclient, ...).

But the supplied patch is a good initial approximation, at least, and
it wouldn't hurt to apply it now to get some packages fixed soon and
to hack the patch later.

-- 
Clear skies,
Justin



Reply to: