Bulletin d'alerte Debian

DLA-2442-1 obfs4proxy -- Mise à jour de sécurité pour LTS

Date du rapport :
10 novembre 2020
Paquets concernés :
obfs4proxy
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2019-11840.
Plus de précisions :

golang-go.crypto a été récemment mis à jour pour le CVE-2019-11840. Cela conduit à ce que tous les paquets utilisant le code affecté soient recompilés pour tenir compte du correctif de sécurité.

  • CVE-2019-11840

    Un problème a été découvert dans la bibliothèque complémentaire de chiffrement de Go, c'est-à-dire, golang-googlecode-go-crypto. Si plus de 256 GiB de séquences de clés sont générés ou si le compteur dépasse 32 bits, l’implémentation d’amd64 générera d’abord une sortie incorrecte, puis reviendra à la séquence précédente. Des répétitions d’octets de séquence peuvent conduire à une perte de confidentialité dans les applications de chiffrement ou à une prédictibilité dans les applications CSPRNG.

Pour Debian 9 Stretch, ce problème a été corrigé dans la version 3 0.0.7-1+deb8u1.

Nous vous recommandons de mettre à jour vos paquets obfs4proxy.

Pour disposer d'un état détaillé sur la sécurité de obfs4proxy, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/obfs4proxy

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.