Bulletin d'alerte Debian

DLA-2460-1 golang-1.8 -- Mise à jour de sécurité pour LTS

Date du rapport :
21 novembre 2020
Paquets concernés :
golang-1.8
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2020-15586, CVE-2020-16845, CVE-2020-28367.
Plus de précisions :

Trois problèmes ont été découverts dans golang-1.8, un compilateur du langage de programmation Go.

  • CVE-2020-15586

    Utiliser le 100-continue dans les en-têtes HTTP reçus par un serveur HTTP peut conduire à une compétition des données impliquant l’écriture de la connexion mise en tampon.

  • CVE-2020-16845

    Certaines entrées non valables pour ReadUvarint ou ReadVarint pourraient permettre à ces fonctions de lire un nombre illimité d’octets à partir de l’argument ByteReader avant de renvoyer une erreur.

  • CVE-2020-28367

    Lors de l’utilisation de cgo, du code arbitraire pourrait être exécuté lors de la compilation.

    Pour Debian 9 Stretch, ces problèmes ont été corrigés dans la version 1.8.1-1+deb9u2.

    Nous vous recommandons de mettre à jour vos paquets golang-1.8.

    Pour disposer d'un état détaillé sur la sécurité de golang-1.8, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/golang-1.8.

    Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.