Bulletin d'alerte Debian

DLA-2474-1 musl -- Mise à jour de sécurité pour LTS

Date du rapport :
1er décembre 2020
Paquets concernés :
musl
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 975365.
Dans le dictionnaire CVE du Mitre : CVE-2020-28928.
Plus de précisions :

Il a été découvert que la fonction wcsnrtombs, dans toutes les versions de libc de musl jusqu’à la version 1.2.1, comportait plusieurs bogues dans la gestion de la taille du tampon de destination lors de la limitation du nombre de caractères d’entrée. Cela pouvait conduire à une boucle infinie sans progression (pas de débordement) ou à une écriture après la fin des tampons de destination.

Pour Debian 9 Stretch, ce problème a été corrigé dans la version 1.1.16-3+deb9u1.

Nous vous recommandons de mettre à jour vos paquets musl.

Pour disposer d'un état détaillé sur la sécurité de musl, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/musl.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.