Debian Security Advisory

DLA-2614-1 busybox -- LTS security update

Date Reported:
01 Apr 2021
Affected Packages:
busybox
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 986217.
In Mitre's CVE dictionary: CVE-2021-28831.
More information:

The gunzip decompressor of Busybox, tiny utilities for small and embedded systems, mishandled the error bit on the huft_build result pointer, with a resultant invalid free or segmentation fault, via malformed gzip data.

For Debian 9 stretch, this problem has been fixed in version 1:1.22.0-19+deb9u2.

We recommend that you upgrade your busybox packages.

For the detailed security status of busybox please refer to its security tracker page at: https://security-tracker.debian.org/tracker/busybox

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS