Debian Security Advisory

DLA-2691-1 libgcrypt20 -- LTS security update

Date Reported:
24 Jun 2021
Affected Packages:
libgcrypt20
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2021-33560.
More information:

An issue has been found in libgcrypt20, a crypto library. Mishandling of ElGamal encryption results in a possible side-channel attack and an interoperability problem with keys not generated by GnuPG/libgcrypt.

For Debian 9 stretch, this problem has been fixed in version 1.7.6-2+deb9u4.

We recommend that you upgrade your libgcrypt20 packages.

For the detailed security status of libgcrypt20 please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libgcrypt20

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS