Debian Security Advisory

DLA-2770-1 weechat -- LTS security update

Date Reported:
30 Sep 2021
Affected Packages:
weechat
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 951289, Bug 993803.
In Mitre's CVE dictionary: CVE-2020-8955, CVE-2020-9759, CVE-2020-9760, CVE-2021-40516.
More information:

Several vulnerabilities were fixed in the chat client WeeChat.

  • CVE-2020-8955

    A crafted irc message 324 (channel mode) could result in a crash.

  • CVE-2020-9759

    A crafted irc message 352 (who) could result in a crash.

  • CVE-2020-9760

    A crafted irc message 005 (setting a new mode for a nick) could result in a crash.

  • CVE-2021-40516

    A crafted WebSocket frame could result in a crash in the Relay plugin.

For Debian 9 stretch, these problems have been fixed in version 1.6-1+deb9u3.

We recommend that you upgrade your weechat packages.

For the detailed security status of weechat please refer to its security tracker page at: https://security-tracker.debian.org/tracker/weechat

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS