Debian Security Advisory

DLA-3013-1 needrestart -- LTS security update

Date Reported:
18 May 2022
Affected Packages:
needrestart
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 1011154.
In Mitre's CVE dictionary: CVE-2022-30688.
More information:

Jakub Wilk discovered a local privilege escalation in needrestart, a utility to check which daemons need to be restarted after library upgrades. Regular expressions to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.

For Debian 9 stretch, this problem has been fixed in version 2.11-3+deb9u2.

We recommend that you upgrade your needrestart packages.

For the detailed security status of needrestart please refer to its security tracker page at: https://security-tracker.debian.org/tracker/needrestart

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS