Bulletin d'alerte Debian

DLA-3024-1 python-django -- Mise à jour de sécurité pour LTS

Date du rapport :
26 mai 2022
Paquets concernés :
python-django
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2020-9402.
Plus de précisions :

Il existait une potentielle vulnérabilité d'injection SQL dans le cadriciel de développement web.

Des données non fiables étaient utilisées comme paramètre de tolérance dans les fonctions et les agrégats de GIS lors de l'utilisation du moteur de base de données Oracle. En passant un niveau de tolérance contrefait de façon appropriée aux fonctions et agrégats de GIS sur Oracle, il était éventuellement possible de casser l'échappement et d'injecter du code SQL malveillant.

  • CVE-2020-9402

    Django 1.11 avant 1.11.29, 2.2 avant 2.2.11, et 3.0 avant 3.0.4 permet une injection SQL si des données non fiables sont utilisées comme paramètre de tolérance dans les fonctions et les agrégats de GIS sur Oracle. En passant un niveau de tolérance contrefait de façon appropriée aux fonctions et agrégats de GIS sur Oracle, il était possible de casser l'échappement et et d'injecter du code SQL malveillant.

Pour Debian 9 Stretch, ces problèmes ont été corrigées dans la version 1:1.10.7-2+deb9u17.

Nous vous recommandons de mettre à jour vos paquets python-django.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.