Debian Security Advisory

DLA-3027-1 neutron -- LTS security update

Date Reported:
26 May 2022
Affected Packages:
neutron
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2021-40085.
More information:

It was discovered that the previous upload to neutron to Debian 9 "Stretch" (ie. version 2:9.1.1-3+deb9u2) was incomplete and did not actually apply the fix for CVE-2021-40085.

  • CVE-2021-40085

    An issue was discovered in OpenStack Neutron before 16.4.1, 17.x before 17.2.1, and 18.x before 18.1.1. Authenticated attackers can reconfigure dnsmasq via a crafted extra_dhcp_opts value.

For Debian 9 Stretch, this has now been fixed in version 2:9.1.1-3+deb9u3.

We recommend that you upgrade your neutron packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS