Debian Security Advisory

DLA-3205-1 inetutils -- LTS security update

Date Reported:
25 Nov 2022
Affected Packages:
inetutils
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 945861, Bug 956084, Bug 993476.
In Mitre's CVE dictionary: CVE-2019-0053, CVE-2021-40491, CVE-2022-39028.
More information:

Several security vulnerabilities were discovered in inetutils, a collection of common network programs.

  • CVE-2019-0053

    inetutils' telnet client doesn't sufficiently validate environment variables, which can lead to stack-based buffer overflows. This issue is limited to local exploitation from restricted shells.

  • CVE-2021-40491

    inetutils' ftp client before 2.2 does not validate addresses returned by PASV/LSPV responses to make sure they match the server address. A malicious server can exploit this flaw to reach services in the client's private network. (This is similar to curl's CVE-2020-8284.)

  • CVE-2022-39028

    inetutils's telnet server through 2.3 has a NULL pointer dereference which a client can trigger by sending 0xff 0xf7 or 0xff 0xf8. In a typical installation, the telnetd application would crash but the telnet service would remain available through inetd. However, if the telnetd application has many crashes within a short time interval, the telnet service would become unavailable after inetd logs a "telnet/tcp server failing (looping), service terminated" error.

For Debian 10 buster, these problems have been fixed in version 2:1.9.4-7+deb10u2.

We recommend that you upgrade your inetutils packages.

For the detailed security status of inetutils please refer to its security tracker page at: https://security-tracker.debian.org/tracker/inetutils

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS