Debian Security Advisory

DLA-3262-1 smarty3 -- LTS security update

Date Reported:
05 Jan 2023
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2018-25047.
More information:

It was discovered that there was a potential cross-site scripting vulnerability in smarty3, a widely-used PHP templating engine.

  • CVE-2018-25047

    In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.

For Debian 10 Buster, this problem has been fixed in version 3.1.33+20180830.1.3a78a21f+selfpack1-1+deb10u2.

We recommend that you upgrade your smarty3 packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: