Kommentarer till utgåvan Debian 11 (bullseye), ARMv7 (EABI hard-float ABI)

The Debian Documentation Project

Detta dokument är fri mjukvara; du kan vidaredistribuera det och/eller modifiera det i enlighet med villkoren i Free Software Foundations GNU General Public License version 2.

Detta program är distribuerat med förhoppning att det ska vara användbart men HELT UTAN GARANTIER; inte ens underförstådd garanti om SÄLJBARHET eller att PASSA ETT SÄRSKILT SYFTE. Läs mer i GNU General Public License för djupare detaljer.

Du borde ha fått en kopia av GNU General Public License tillsammans med det här programmet; om inte, skriv till Free Software Foundation, Inc., 51 Franklin Street. Fifth Floor, Boston, MA, 02110-1301 USA.

Licenstexten kan också hämtas på https://www.gnu.org/licenses/gpl-2.0.html och /usr/share/common-licenses/GPL-2 på Debian-system.


Innehållsförteckning

1. Introduktion
1.1. Rapportera fel i det här dokumentet
1.2. Bidra med uppgraderingsrapporter
1.3. Källor för det här dokumentet
2. Vad är nytt i Debian 11
2.1. Arkitekturer med stöd
2.2. Vad är nytt i distributionen?
2.2.1. Skrivbordsmiljöer och kända paket
2.2.2. Utskrifter och scanning utan drivrutiner
2.2.3. Nytt generellt kommando open
2.2.4. Control groups v2
2.2.5. Beständig systemd-journal
2.2.6. Nytt sätt att skriva med Fcitx 5
2.2.7. Nyheter från Debian Med Blend
2.2.8. Stöd för exFAT direkt i kärnan
2.2.9. Förbättrade översättningar av manualsidor
2.2.10. Improved support for alternative init systems
3. Installationssystem
3.1. Vad är nytt i installationssystemet?
3.1.1. Hjälp för att installera fast progamvara
3.1.2. Automatisk installation
3.2. Avbildningar för containrar och virtuella maskiner
4. Uppgraderingar från Debian 10 (buster)
4.1. Förberedelse inför uppgraderingen
4.1.1. Säkerhetskopiera all data och konfigurationsinformation
4.1.2. Informera användarna i förväg
4.1.3. Förbered för att tjänster blir oåtkomliga
4.1.4. Förbered för återställning
4.1.5. Förbered en säker miljö för uppgraderingen
4.2. Börja med en ren Debian
4.2.1. Uppgradera till Debian 10 (buster)
4.2.2. Ta bort icke-Debian-paket
4.2.3. Uppgradera till senaste punkt-utgåvan
4.2.4. Förbered paketdatabasen
4.2.5. Ta bort föråldrade paket
4.2.6. Städa upp kvarlämnade inställningsfiler
4.2.7. Säkerhets-kategorin
4.2.8. Avsnittet proposed-updates
4.2.9. Inofficiella källor
4.2.10. Inaktivera APT-nålning
4.2.11. Kontrollera paketstatus
4.3. Förbered källor för APT
4.3.1. Lägg till APT-källor från Internet
4.3.2. Lägg till APT-källor för en lokal spegelserver
4.3.3. Lägg till APT-källor från optisk media
4.4. Uppgradering av paket
4.4.1. Spela in sessionen
4.4.2. Uppdatering av paketlistan
4.4.3. Se till att du har tillräckligt med utrymme för uppgraderingen
4.4.4. Minimal systemuppgradering
4.4.5. Uppgradering av systemet
4.5. Möjliga problem under uppgraderingen
4.5.1. Dist-upgrade misslyckas med meddelandet Could not perform immediate configuration
4.5.2. Förväntade raderingar
4.5.3. Konflikter vid förberoende-loop
4.5.4. Filkonflikter
4.5.5. Inställningsförändringar
4.5.6. Flytt av sessionen till konsoll
4.6. Uppgradering av kärna och relaterade paket
4.6.1. Installera metapaketet för kärnan
4.7. Förberedelse inför nästa utgåva
4.7.1. Utrensning av borttagna paket
4.8. Föråldrade paket
4.8.1. Tomma övergångspaket
5. Problemområden att känna till för bullseye
5.1. Specifik uppgraderingsinformation för bullseye
5.1.1. Filsystemet XFS har inte längre stöd för barrier/nobarrier
5.1.2. Förändrat upplägg på säkerhetsakrivet
5.1.3. Lösenord använder yescrypt som standardfunktion för hashning
5.1.4. NSS NIS och NIS+ kräver nya paket
5.1.5. Hantering av fragmenterade inställningsfiler för unbound
5.1.6. utfasning av parametrar i rsync
5.1.7. Hantering av utökningar för Vim
5.1.8. OpenStack och cgroups v1
5.1.9. OpenStack API policy-filer
5.1.10. sendmail kommer att vara otillgängligt under uppgraderingen
5.1.11. FUSE 3
5.1.12. GnuPGs option-fil
5.1.13. Linux aktiverar namespace som standard
5.1.14. Linux förhindrar opriviligierade anrop till bpf() som standard
5.1.15. Redmine saknas i bullseye
5.1.16. Exim 4.94
5.1.17. Upptäckt av SCSI-enheter är inte deterministisk
5.1.18. rdiff-backup kräver samkörd uppgradering av klient och server
5.1.19. Problem med Intels microkod
5.1.20. Uppgraderingar som berör libgc1c2 kräver två körningar
5.1.21. fail2ban kan inte skicka e-post med mail från bsd-mailx
5.1.22. Inga nya SSH-anslutningar under uppgraderingen
5.1.23. Att göra efter uppgradering före omstart
5.2. Delar som inte är helt bundna till uppgraderingsprocessen
5.2.1. Begränsningar i säkerhetsstödet
5.2.2. Tillgång till Gnomes inställningsapplikation utan att använda en mus
5.2.3. Räddningsläget kan inte användas utan att ha tillgång till lösenordet för root
5.3. Föråldring och utfasning
5.3.1. Föråldrade paket
5.3.2. Utfasning av komponenter för bullseye
5.4. Kända allvarliga fel
6. Mer information om Debian
6.1. Ytterligare läsning
6.2. Få hjälp
6.2.1. Sändlistor
6.2.2. Internet Relay Chat
6.3. Rapportera fel
6.4. Att bidra till Debian
A. Hantera ditt buster-system före uppgraderingen
A.1. Uppgradering av ditt buster-system
A.2. Kontrollera dina APT sources.list-filer
A.3. Ta bort oanvända inställningsfiler
B. Bidrag till Kommentarer till utgåvan
Index
Gloslista