Uwagi do wydania, do dystrybucji Debian 11 (bullseye), System z

The Debian Documentation Project

Niniejszy dokument jest wolnym oprogramowaniem. Można go rozpowszechniać i/lub modyfikować zgodnie z warunkami Licencji Publicznej GNU w wersji 2, opublikowanej przez Fundację Wolnego Oprogramowania.

Niniejszy program rozpowszechniany jest w nadziei, iż będzie on użyteczny - jednak BEZ JAKIEJKOLWIEK GWARANCJI, nawet domyślnej gwarancji PRZYDATNOŚCI HANDLOWEJ albo PRZYDATNOŚCI DO OKREŚLONYCH ZASTOSOWAŃ. Więcej informacji zawiera Powszechna Licencja Publiczna GNU.

Do niniejszego dokumentu powinien być dołączony egzemplarz Powszechnej Licencji Publicznej GNU (GNU General Public License); jeśli nie - proszę napisać do Free Software Foundation, Inc., 675 Mass Ave,Cambridge, MA 02139, USA.

The license text can also be found at https://www.gnu.org/licenses/gpl-2.0.html and /usr/share/common-licenses/GPL-2 on Debian systems.


Spis treści

1. Wstęp
1.1. Zgłaszanie błędów w tym dokumencie
1.2. Wysyłanie sprawozdań aktualizacji
1.3. Źródła niniejszego dokumentu
2. Nowości w dystrybucji Debian 11
2.1. Obsługiwane architektury
2.2. Co nowego w dystrybucji?
2.2.1. Desktops and well known packages
2.2.2. Driverless scanning and printing
2.2.3. New generic open command
2.2.4. Control groups v2
2.2.5. Persistent systemd journal
2.2.6. New Fcitx 5 Input Method
2.2.7. Wieści z odmiany Debian Med
2.2.8. Kernel support for exFAT
2.2.9. Improved man page translations
2.2.10. Improved support for alternative init systems
3. System instalacyjny
3.1. Co nowego w systemie instalacyjnym?
3.1.1. Help with installation of firmware
3.1.2. Instalacja automatyczna
3.2. Container and Virtual Machine images
4. Aktualizacja z Debiana 10 (buster)
4.1. Przygotowanie do aktualizacji
4.1.1. Kopia zapasowa danych i konfiguracji
4.1.2. Uprzednie ostrzeżenie użytkowników
4.1.3. Przygotowanie do przestoju usług
4.1.4. Przygotowanie do odzyskiwania
4.1.5. Przygotowanie bezpiecznego środowiska do uaktualnienia
4.2. Start from pure Debian
4.2.1. Upgrade to Debian 10 (buster)
4.2.2. Remove non-Debian packages
4.2.3. Upgrade to latest point release
4.2.4. Prepare the package database
4.2.5. Remove obsolete packages
4.2.6. Clean up leftover configuration files
4.2.7. The security section
4.2.8. Sekcja proposed-updates
4.2.9. Nieoficjalne źródła
4.2.10. Wyłączenie priorytetów APT-a (APT pinning)
4.2.11. Check package status
4.3. Preparing APT source-list files
4.3.1. Dodanie internetowych źródeł APT-a
4.3.2. Dodanie źródeł APT-a do lokalnego serwera lustrzanego
4.3.3. Dodanie źródeł APT-a do nośników optycznych
4.4. Aktualizacja pakietów
4.4.1. Zapisanie sesji
4.4.2. Aktualizowanie listy pakietów
4.4.3. Zapewnienie wystarczającej ilości wolnego miejsca
4.4.4. Minimalna aktualizacja systemu
4.4.5. Aktualizacja systemu
4.5. Możliwe problemy przy aktualizacji
4.5.1. Podczas aktualizacji dystrybucji pojawia się błąd Nie udało się wykonać natychmiastowej konfiguracji.
4.5.2. Spodziewane usunięcia pakietów
4.5.3. Konflikty lub pętle wymaga wstępnie
4.5.4. Konflikty plików
4.5.5. Zmiany konfiguracji
4.5.6. Zmiany sesji na konsoli
4.6. Aktualizacja jądra i powiązanych pakietów
4.6.1. Instalowanie metapakietu jądra
4.7. Przygotowanie do kolejnego wydania
4.7.1. Czyszczenie usuniętych pakietów
4.8. Przestarzałe pakiety
4.8.1. Transitional dummy packages
5. Problemy, które należy mieć na uwadze, a dotyczące wydania bullseye
5.1. Uwagi dotyczące aktualizacji do bullseye
5.1.1. The XFS file system no longer supports barrier/nobarrier option
5.1.2. Changed security archive layout
5.1.3. Password hashing uses yescrypt by default
5.1.4. NSS NIS and NIS+ support require new packages
5.1.5. Config file fragment handling in unbound
5.1.6. rsync parameter deprecation
5.1.7. Vim addons handling
5.1.8. OpenStack and cgroups v1
5.1.9. OpenStack API policy files
5.1.10. sendmail downtime during upgrade
5.1.11. FUSE 3
5.1.12. GnuPG options file
5.1.13. Linux enables user namespaces by default
5.1.14. Linux disables unprivileged calls to bpf() by default
5.1.15. redmine missing in bullseye
5.1.16. Exim 4.94
5.1.17. SCSI device probing is non-deterministic
5.1.18. rdiff-backup require lockstep upgrade of server and client
5.1.19. Intel CPU microcode issues
5.1.20. Upgrades involving libgc1c2 need two runs
5.1.21. fail2ban can't send e-mail using mail from bsd-mailx
5.1.22. No new SSH connections possible during upgrade
5.1.23. Sprawy do zrobienia przed ponownym uruchomieniem
5.2. Items not limited to the upgrade process
5.2.1. Ograniczenia we wsparciu bezpieczeństwa
5.2.2. Accessing GNOME Settings app without mouse
5.2.3. The rescue boot option is unusable without a root password
5.3. Obsolescence and deprecation
5.3.1. Znane pakiety oznaczone jako przestarzałe
5.3.2. Przestarzałe składniki w wydaniu bullseye
5.4. Known severe bugs
6. Więcej informacji na temat projektu Debian
6.1. Dodatkowe informacje
6.2. Pomoc
6.2.1. Listy dyskusyjne
6.2.2. IRC
6.3. Zgłaszanie błędów
6.4. Uczestnictwo w rozwoju Debiana
A. Zarządzanie wydaniem buster przed aktualizacją
A.1. Uaktualnienie wydania buster
A.2. Checking your APT source-list files
A.3. Usunięcie przestarzałych plików konfiguracyjnych
B. Współtwórcy uwag do wydania
Indeks
glosariusz