Annexe A. Gérer le système Stretch avant la mise à niveau

Table des matières

A.1. Mettre à niveau le système Stretch
A.2. Vérifier les fichiers source-list d'APT
A.3. Supprimer les fichiers de configuration obsolètes
A.4. Mettre à niveau les anciens paramètres linguistiques régionaux vers UTF-8

Cette annexe contient des informations sur la façon de vous assurer que vous pouvez installer ou mettre à jour des paquets de Stretch avant de faire une mise à niveau vers Buster. Cela ne devrait être nécessaire que dans des situations spécifiques.

A.1. Mettre à niveau le système Stretch

En gros, cela n'est pas différent de toutes les autres mises à niveau de Stretch qui ont déjà été faites. La seule différence est que vous devez tout d'abord vous assurer que la liste de paquets contient toujours des références à Stretch comme expliqué en Section A.2, « Vérifier les fichiers source-list d'APT » .

Si vous mettez le système à niveau en utilisant un miroir Debian, il sera automatiquement mis à niveau vers la dernière version mineure de Stretch.

A.2. Vérifier les fichiers source-list d'APT

If any of the lines in your APT source-list files (see sources.list(5)) contain references to « stable », this is effectively pointing to buster already. This might not be what you want if you are not yet ready for the upgrade. If you have already run apt update, you can still get back without problems by following the procedure below.

Si des paquets de Buster ont déjà été installés, il n'y a probablement plus beaucoup d'intérêt à installer des paquets de Stretch. Dans ce cas, vous devrez décider vous-même si vous voulez continuer ainsi ou non. Il est possible de revenir à des versions antérieures pour des paquets, mais cela n'est pas traité ici.

En tant que superutilisateur, ouvrez le fichier source-list d'APT concerné (tel que /etc/apt/sources.list) avec votre éditeur favori et recherchez une référence à « stable » dans toutes les lignes commençant par deb http:, deb https:, deb tor+http:, deb tor+https:, URIs: http:, URIs: https:, URIs: tor+http: ou URIs: tor+https:. Si vous en trouvez, changez stable en stretch.

Si des lignes commencent par deb file: ou URIs: file:, vous devrez vérifier vous-même si l'emplacement auquel elles se réfèrent contient une archive de Stretch ou de Buster.

[Important]Important

Ne changez pas les lignes qui commencent par deb cdrom: ou URIs: cdrom:. Faire cela invaliderait la ligne et vous devriez à nouveau exécuter apt-cdrom. Ne vous inquiétez pas si une ligne de source cdrom se réfère à « unstable ». C'est normal, bien que cela paraisse trompeur.

Si des modifications ont déjà été effectuées, sauvegardez le fichier et exécutez :

# apt update

pour rafraîchir la liste des paquets.

A.3. Supprimer les fichiers de configuration obsolètes

Avant de mettre à jour le système vers Buster, il est recommandé de supprimer les vieux fichiers de configuration (tels que les fichiers *.dpkg-{new,old} dans /etc) du système.

A.4. Mettre à niveau les anciens paramètres linguistiques régionaux vers UTF-8

L'utilisation d'un ancien paramètre linguistique régional non UTF-8 n'est plus prise en charge depuis longtemps par les environnements de bureaux et les principaux projets logiciels. Ce type de paramètre linguistique devrait être mis à niveau en exécutant la commande dpkg-reconfigure locales et en choisissant des paramètres linguistiques compatibles UTF-8 par défaut. De plus, vous devriez vous assurer que les utilisateurs ne passent pas outre les valeurs par défaut pour utiliser d'anciens paramètres linguistiques régionaux dans leur environnement.