Aviso de seguridad de Debian

DSA-373-1 autorespond -- desbordamiento de buffer

Fecha del informe:
16 de ago de 2003
Paquetes afectados:
autorespond
Vulnerable:
Referencias a bases de datos de seguridad:
En la base de datos de Bugtraq (en SecurityFocus): Id. en BugTraq 8436.
En el diccionario CVE de Mitre: CVE-2003-0654.
Información adicional:

Christian Jaeger descubrió un desbordamiento de buffer en autorespond, software para responder correo automáticamente con qmail. Potencialmente, esta vulnerabilidad la prodría aprovechar un atacante remoto para obtener los privilegios del usuario que hubiera configurado qmail para que reenviara los mensajes para una respuesta automática. Parece ser que esta vulnerabilidad no se puede aprovechar en la práctica debido a los límites de la longitud de la entrada problemática, pero puede haber situaciones en las que estos límites no se consideren.

Para la distribución estable (woody), este problema se ha corregido en la versión 2.0.2-2woody1.

Para la distribución inestable (sid), este problema se corregirá en breve.

Le recomendamos que actualice el paquete autorespond.

Arreglado en:

Debian GNU/Linux 3.0 (woody)

Fuentes:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1.dsc
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1.diff.gz
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/contrib/a/autorespond/autorespond_2.0.2-2woody1_sparc.deb

Las sumas MD5 de los ficheros que se listan están disponibles en el aviso original.