Publication de la mise à jour de Debian 9.3

9 décembre 2017

Le projet Debian a l'honneur d'annoncer la troisième mise à jour de sa distribution stable Debian 9 (nommée stretch). Tout en réglant quelques problèmes importants, cette mise à jour corrige principalement des problèmes de sécurité de la version stable. Les annonces de sécurité ont déjà été publiées séparément et sont simplement référencées dans ce document.

Veuillez noter que cette mise à jour ne constitue pas une nouvelle version de Debian 9 mais seulement une mise à jour de certains des paquets qu'elle contient. Il n'est pas nécessaire de jeter les anciens médias de la version stretch mais simplement de faire une mise à jour à l’aide d’un miroir Debian après une installation, pour déclencher la mise à jour de tout paquet obsolète.

Ceux qui installent fréquemment les mises à jour à partir de security.debian.org n'auront pas beaucoup de paquets à mettre à jour et la plupart des mises à jour de security.debian.org sont comprises dans cette mise à jour.

De nouvelles images d'installation seront prochainement disponibles à leurs emplacements habituels.

Mettre à jour une installation vers cette révision peut se faire en faisant pointer le système de gestion de paquets sur l'un des nombreux miroirs HTTP de Debian. Une liste complète des miroirs est disponible à l'adresse :

https://www.debian.org/mirror/list

Corrections de bogues divers

Cette mise à jour de la version stable apporte quelques corrections importantes aux paquets suivants :

Paquet Raison
abiword Correction de clignotement
base-files Mise à jour pour cette version
berusky Correction de plantage au démarrage avec certaines configurations de cartes vidéo
charmtimetracker Correction de dépendance binaire manquante à libqt5sql5-sqlite
corebird Augmentation de la longueur maximum des tweets à 280 caractères
dbus Lors de l'analyse de la configuration de dbus-daemon, ne pas retarder le démarrage si une entropie de qualité n'est pas encore disponible ; lors de l'utilisation de l'interface Monitoring, correspondance des filtres de message qui précisent correctement une destination ; accroissement de l'attente de listen() des sockets AF_UNIX au maximum possible, réduisant les échecs de connexion sous forte charge
debian-edu-doc Incorporation des mises à jour de la documentation et des traductions relatives à Stretch à partir d'unstable et du wiki ; documentation/common/edu.css.xml : amélioration de la lisibilité du manuel en HTML
debian-installer Reconstruction pour cette version
dehydrated Mise à jour de l'URL de l'accord de licence du souscripteur
doit Ajout de Breaks: nikola (<< 7.6.0-1~) pour s'assurer de son retrait lors des mises à niveau à partir de Jessie
eclipse-titan Reconstruction avec la version actuelle de GCC de Stretch
fig2dev Ajout de vérification des entrées dans les fichiers FIG [CVE-2017-16899] ; vérification des entrées des motifs de remplissage
flickcurl Correction de la récupération de jeton oauth ; évitement de corruption de double libération durant l'authentification
flightgear Évitement de l'écrasement de fichiers arbitraires par des modules malveillants [CVE-2017-13709]
ganeti Rétroportage de la prise en charge de l'amont des clés SSH non DSA ; correction du basculement à partir de nœuds morts lors de l'utilisation d'extstorage ; correction de import/export/move d'instance avec les versions actuelles de socat
gdm3 Rétroportage de plusieurs correctifs pour corriger la prise en charge de XDMCP
getmail4 Correction d'un problème lié à des empreintes mal formées
grok Correction de bogue des alias de pointeur ; libgrok-dev : ajout de dépendances manquantes à libgrok1 et libtokyocabinet-dev
gunicorn Abandon de Pre-Depends à dpkg-dev inutile qui provoquait l'introduction d'un compilateur comme dépendance par gunicorn et python-gunicorn
icu Correction de double libération dans createMetazoneMappings() [CVE-2017-14952]
inn2 [i386] Reconstruction pour prendre le chemin correct vers le binaire gzip
iproute2 Correction d'erreur de segmentation dans tc avec iptables 1.6
jdcal Correction de dépendances de Python3
kde-gtk-config Correction des boutons d'aperçu dans l'interface utilisateur de KDE-GTK-config
lasi liblasi-dev : ajout de dépendances manquantes à libpango1.0-dev et libfreetype6-dev
libdatetime-timezone-perl Mise à jour des données incluses
libdbd-firebird-perl Correction de la récupération des valeurs decimal(x,y) entre -1 et 0
libdbi Réactivation de l'appel à _error_handler_call dans dbi_result_next_row()
liblog-log4perl-perl Contournement de l'interdiction par Perl 5.24 de la présence conjointe de syswrite et utf8
liblouis Correction de problèmes de dépassement de tampon et d'utilisation de mémoire après libération [CVE-2017-13738 CVE-2017-13739 CVE-2017-13740 CVE-2017-13741 CVE-2017-13742 CVE-2017-13743 CVE-2017-13744]
libmpd libmpd-dev : ajout de dépendance manquante à libglib2.0-dev
libofx Corrections de sécurité [CVE-2017-2816 CVE-2017-14731]
libxkbcommon libxkbcommon-x11-dev : ajout de dépendance manquante à libxkbcommon-dev
libxsettings-client Ajout de la dépendance manquante libxsettings-client-dev -> libxsettings-dev
linux xen/time : pas de réduction des temps volés (« steal time ») après une migration à chaud sur xen ; nouvelle version stable du noyau 4.9.65
live-config Configuration d'autologin pour les images live KDE/Plasma
lxc Pas de codage en dur de la liste des versions valables de Debian, permettant la création de conteneurs pour stable, buster, testing et unstable ; pas d'insertion des locale C.* dans /etc/locale.gen
mongodb Correction d'erreur de segmentation/FTBFS sur ARM64 avec des adresses virtuelles 48 bits, d'erreur de segmentation GC de spidermonkey lors de la construction avec GCC 6 ; mongodb.service : démarrage après network.target
openssh Test de la configuration avant le démarrage ou le rechargement de sshd sous systemd ; ajustement des motifs de compatibilité pour WinSCP afin d'identifier correctement les versions qui implémentent seulement l'ancien schéma d'échange de groupe DH ; faire que -- avant le nom d'hôte arrête le traitement d'argument et également après le nom d'hôte
pdns Correction de casse de nom incorrecte dans la génération de NSEC3 ; ajout de vérifications manquantes sur les opérations de l'API [CVE-2017-15091]
pdns-recursor Corrections de sécurité : validation insuffisante des signatures DNSSEC [CVE-2017-15090] ; script inter-site dans l'interface web [CVE-2017-15092] ; injection de fichier de configuration dans l'API [CVE-2017-15093] ; fuite de mémoire dans l'analyse de DNSSEC [CVE-2017-15094]
postgresql-9.6 Version amont de correction de bogues
publicsuffix Mise à jour des données incluses
pyosmium Version amont de correction de bogues : pas de fonction de traitement appelée lors de l'utilisation du service de réplication ou l'utilisation de Reader à la place de file
python-diff-match-patch Ajout de dépendance manquante à python3 pour le paquet Python 3
python-inflect Correction de dépendances de Python 3
python-tablib Chargement sûr de YAML [CVE-2017-2810]
python2.7 Correction de dépassement d'entier dans PyString_DecodeEscape [CVE-2017-1000158] ; prise en charge de tous les groupes dans la communication TLS
qtcurve Correction de plantages en utilisant strncmp() à la place de memcmp()
ruby-httparty Assouplissement de dépendance de version dans la dépendance de gem à json
ruby-ox Plantage évité avec du code XML non valable passé à Oj.parse_obj() [CVE-2017-15928]
ruby-pygments.rb Fermeture de trop nombreux fichiers évitée lors du démarrage de mentos, qui peut provoquer des échecs de construction dans d'autres paquets sur les systèmes les plus lents
schroot Correction du fichier de complétement de commandes pour bash ; ajout du fichier de service systemd avec Type=oneshot pour éviter les problèmes de délai avec de trop nombreuses sessions ouvertes
simutrans Réactivation du son pour simutrans ; passage de SDL au dorsal mixer_sdl
sitesummary Ajustement du module de vérification de version de noyau de nagios pour qu'il fonctionne avec les noyaux 4.x
slic3r Correction de dépendance manquante à perlapi-*
spamassassin Désactivation de bb.barracudacentral.org ; mise à jour du fichier unit de systemd pour utiliser le même du fichier d'identifiant de processus que celui utilisé dans le script sysvinit ; mise à jour des dépendances d'unit de systemd pour inclure le network et syslog ; correction de l'invocation inappropriée de invoke-rc.d dans le script de cron
sqldeveloper-package Correction d'échecs de construction
sqlite3 Correction de lecture hors limites de tampon de tas à cause de blobs RTree sous-dimensionnés [CVE-2017-10989]
syslinux Correction de mappage d'adresse de blocs logiques à physiques btrfs ; correction de problème de démarrage pour les micrologiciels anciens du BIOS en corrigeant l'ordre C/H/S ; prise en charge de la fonctionnalité 64bit d'ext4
tdbcodbc Correction du bogue dans la recherche de bibliothèque ODBC
tor Ajout du répertoire de tiers de confiance Bastet ; correction d'un échec d'assertion basé sur le temps ; mise à jour de geoip et geoip6 vers la base de données de pays Maxmind GeoLite2 du 4 octobre 2017
tzdata Nouvelle version amont
udftools Correction de chemin pour pktsetup dans le script init d'udftools
weechat logger : appel de strftime avant le remplacement des variables du tampon local [CVE-2017-14727]
xml2 Correction de corruption lors du traitement de fichiers UTF-8, utilisation de chaîne pour l'outil 2csv
xrdp Correction de charge importante du processeur à l'arrêt de SSL
zsh Reconstruction pour introduire les bibliothèques mises à jour pour zsh-static

Mises à jour de sécurité

Cette révision ajoute les mises à jour de sécurité suivantes à la version stable. L'équipe de sécurité a déjà publié une annonce pour chacune de ces mises à jour :

Identifiant Paquet
DSA-3989 dnsmasq
DSA-3990 asterisk
DSA-3991 qemu
DSA-3992 curl
DSA-3993 tor
DSA-3994 nautilus
DSA-3995 libxfont
DSA-3996 ffmpeg
DSA-3997 wordpress
DSA-3998 nss
DSA-3999 wpa
DSA-4000 xorg-server
DSA-4001 yadifa
DSA-4003 libvirt
DSA-4004 jackson-databind
DSA-4006 mupdf
DSA-4007 curl
DSA-4008 wget
DSA-4009 shadowsocks-libev
DSA-4011 quagga
DSA-4013 openjpeg2
DSA-4014 thunderbird
DSA-4015 openjdk-8
DSA-4016 irssi
DSA-4017 openssl1.0
DSA-4018 openssl
DSA-4019 imagemagick
DSA-4020 chromium-browser
DSA-4021 otrs2
DSA-4023 slurm-llnl
DSA-4024 chromium-browser
DSA-4025 libpam4j
DSA-4026 bchunk
DSA-4028 postgresql-9.6
DSA-4029 postgresql-common
DSA-4030 roundcube
DSA-4031 ruby2.3
DSA-4032 imagemagick
DSA-4033 konversation
DSA-4034 varnish
DSA-4035 firefox-esr
DSA-4036 mediawiki
DSA-4037 jackson-databind
DSA-4038 shibboleth-sp2
DSA-4039 opensaml2
DSA-4041 procmail
DSA-4042 libxml-libxml-perl
DSA-4043 samba
DSA-4044 swauth
DSA-4045 vlc
DSA-4047 otrs2
DSA-4049 ffmpeg
DSA-4050 xen
DSA-4051 curl
DSA-4052 bzr
DSA-4053 exim4

Paquets supprimés

Les paquets suivants ont été supprimés à cause de circonstances hors de notre contrôle :

Paquet Raison
libnet-ping-external-perl non maintenu, problèmes de sécurité

Installateur Debian

L'installateur a été mis à jour pour inclure les correctifs incorporés dans cette version de stable.

URL

Liste complète des paquets qui ont été modifiés dans cette version :

http://ftp.debian.org/debian/dists/stretch/ChangeLog

Adresse de l'actuelle distribution stable :

http://ftp.debian.org/debian/dists/stable/

Mises à jour proposées à la distribution stable :

http://ftp.debian.org/debian/dists/proposed-updates

Informations sur la distribution stable (notes de publication, errata, etc.) :

https://www.debian.org/releases/stable/

Annonces et informations de sécurité :

https://security.debian.org/

À propos de Debian

Le projet Debian est une association de développeurs de logiciels libres qui offrent volontairement leur temps et leurs efforts pour produire le système d'exploitation complètement libre Debian.

Contacts

Pour de plus amples informations, veuillez consulter le site Internet de Debian https://www.debian.org/ ou envoyez un courrier électronique à <press@debian.org> ou contactez l'équipe de publication de la version stable à <debian-release@lists.debian.org>.